PHP-Problem: ownCloud stellt bei Strato Umlaute plötzlich falsch dar

23 September 2014 5 Kommentare Autor: Jürgen (jdo)

Nach meinem Urlaub stellte ich mir Erstaunen fest, dass die Umlaute bei meiner ownCloud auf dem Strato-Server (nicht die interne auf der ZBOX) plötzlich keine Umlaute und andere Sonderzeichen mehr darstellen will. Ich habe definitiv an der ownCloud nichts umgestellt und das Ganze ist etwas seltsam. Der Browser war nicht Schuld, da das gleiche Phänomen mit Firefox, Chromium und Opera auftrat.

Nun hat mir die ownCloud gesagt, dass es ein Update auf Version 7.0.2 gibt. Vielleicht löst eine Aktualisierung das Problem. Tut es aber nicht.

ownCloud stellt Umlaute falsch dar

ownCloud stellt Umlaute falsch dar

Ich weiß, dass Strato eine neue PHP-Version kürzlich zur Verfügung gestellt hat und in meinem Paket habe ich diese als Standard eingestellt. Wahrscheinlich liegt es daran.

Bei Strato gibt es die Möglichkeit, eine eigene php.ini zu erstellen. Man muss allerdings wissen, dass sich die php.ini nicht in Unterverzeichnisse vererbt. Bei der ownCloud reicht es zum Glück, die php.ini in das Wurzelverzeichnis des Pakets zu kopieren. Möchte man ein ähnliches Problem bei einer anderen Software lösen, muss man die Datei möglicherweise auch in diverse Unterverzeichnisse kopieren.

php.ini für ownCloud und Strato anpassen

Was mir geholfen hat, den Missstand zu adressieren. Ich habe eine Datei php.ini im ownCloud-Verszeichnis angelegt und dort lediglich diese Zeile hinterlegt:

default_charset = "utf-8"

Das hat schon ausgereicht und nun ist das Umlaut-Problem behoben. Etwas lästig ist die Sache schon. Nun kann ich sämtliche selbst geschriebenen Tools und so weiter prüfen, ob ich diese Zeile am Anfang meiner php-Dateien eingefügt habe:

header("Content-Type: text/html; charset=UTF-8");

Ein möglicher Ansatz wäre auch noch der Versuch, das über den Apache Webserver und die Datei .htaccess zu regeln. Da müsste man Folgendes hinzufügen:

AddDefaultCharset UTF-8

P.S: Was seltsam ist – WordPress hat mit der neuen Version anscheinend keine Probleme. Ich hab mir die Header-Dateien nicht angesehen. Vermutlich legt WordPress das default_charset an anderer Stelle fest. Die Header-Datei bei der ownCloud zu verändern wäre allerdings unschön, da diese Änderung mit einem Update möglicherweise überschrieben wird. Der Trick mit der php.ini funktioniert aber.

P.P.S: Hier findet man die Standard-Einstellungen der unterschiedlichen PHP-Versionen bei Strato.

Du kannst gerne Deinen Senf zu diesem Beitrag geben: Hier geht es zu den Kommentaren




Schreiben macht durstig! Eine kleine Erfrischung kann daher nie schaden. Wem dieser freie Artikel gefallen hat, der darf mir gerne einen frisch gezapften Hopfen-Tee ausgeben (Paypal - der Spenden-Knopf
oder bitcoin - Adresse: 1NacVNwcLLePUVv8uSafu5Ykdwh8QyDfgK). Ich freue mich über jede noch so kleine Spende. Vielen Dank und Prost!
 Alle Kommentare als Feed abonnieren

5 Kommentare zu “PHP-Problem: ownCloud stellt bei Strato Umlaute plötzlich falsch dar”

  1. Dieses Problem trat bei mir ebenfalls auf. Ursache war eine zu alte PHP-Version (5.3.x) in Kombination mit dem mitgelieferten Updater.
    Spiele ich die Updates hingegen direkt via FTP-Upload ein, gibt es keine Probleme, weswegen ich auf den mitgelieferten Updater nach Möglichkeit verzichte.

    Ich habe bereits beim Upgrade von v5 auf v6.0.0a ein entsprechendes Ticket im Bugtracker verfasst.
    https://github.com/owncloud/core/issues/6481

    • jdo sagt:

      Ich habe nicht den eingebauten Updater verwendet, sondern Konsole und rsync. Bei anderen Unterseiten trat das gleichen Problem auf - zum Beispiel bei den Wallpapers - ist mittlerweile auch gefixt.

  2. […] ownCloud stellt bei Strato Umlaute plötzlich falsch dar Zum Original Blog […]

  3. Lars sagt:

    Hallo,

    Bei mir ist die zeileAddDefaultCharset UTF-8 bereits drin (Owncloud 7.0.4) trotzdem werden die umlaute nicht richtig dargestellt.

    Was kann ich mich tuen? Ist Strato Webspace Basic.

    Lg Lars

  4. Lars sagt:

    Hallo, das gleiche Problem hatte ich mit Owncloud bei Strato Webspace Basic. Voreingestellt war PHP 5.6 nachdem ich zurück bin auf 5.5 hab ich keine Probleme mehr... Danke für den Tipp. 😉

Antworten