Nextcloud warnt inzwischen auch bei zu alter PHP-Version

Ein Kommentar Autor: Jürgen (jdo)

Normalerweise aktualisiere ich die Nextcloud via Kommandozeile, weil mir das lieber als das Geklicke ist. Ab und zu schadet es aber auch nicht, die Einstellungen im Browser als Administrator aufzurufen. Ich habe das länger nicht mehr gemacht, werde es aber künftig wieder nach jedem Upgrade tun.

Zunächst einmal bekommst Du Warnungen, wenn irgendwelche Sachen bei der Datenbank fehlen. Was ich gestern aber auch noch gesehen habe – eine Warnung wegen der PHP-Version. Die Warnung wird sogar von einer Nextcloud 19 ausgesprochen.

Nextcloud warnt bei nicht mehr aktueller PHP-Version

Nextcloud warnt bei nicht mehr aktueller PHP-Version

Ich benutze also PHP 7.2 und es ist bereits bekannt, dass Nextcloud 20 die letzte Version ist, die diese PHP-Version unterstützt. Die Warnung im Administrations-Bereich ist mir aber noch nie aufgefallen.

Finde ich gut

Es ist auf jeden Fall kein Nachteil, die Leute früh genug zu warnen. In Panik musst Du nicht verfallen. Version 19 wird sicherlich noch eine Weile unterstützt. Dennoch solltest Du Dir vielleicht einen Plan machen, wie Du die PHP-Version oder das Betriebssystem aktualisierst.

Für unterstützte Ubuntu-Versionen gibt es ein PPA, in dem sich unterstützte PHP-Varianten befinden. Damit habe ich zum Beispiel PHP 7.4 auf einem Ubuntu 18.04 installiert. Der Plan ist es auf jeden Fall, bis 2023 auszuhalten, weil dann ein Umstieg auf eine neuere Ubuntu-LTS-Version unausweichlich ist.

Bei meinem Bekannten mache ich vielleicht in absehbarer Zeit ein Upgrade von Bionic auf Focal. Allerdings ist das ein größerer Eingriff, der ein gutes Backup voraussetzt. Da es sich um einen VPS handelt, werde ich auch einen Snapshot machen.

Der Plan ist:

  • Wochenende abwarten, wenn keiner bei denen die Nextcloud benutzt
  • Das Ding in den Wartungsmodus versetzen
  • Backup manuell anstoßen (läuft normalerweise nachts)
  • Snapshot des Systems / VPS machen
  • Upgrade auf Focal Fossa
  • Prüfen, ob das System wieder läuft

Sollte das Upgrade nicht klappen, wird das System via Snapshot wiederhergestellt und muss dann eben bis 2023 durchhalten. Danach wird die NC-Installation einfach auf einen neuen Server umgezogen.

Dich interessieren Kryptowährungen? Ich handle via Binance*.

Am schnellsten kaufst Du Kryptowährungen / Bitcoin über Coinbase*.

Du kannst gerne Deinen Senf zu diesem Beitrag geben: Hier geht es zu den Kommentaren




NordVPN - günstig und ideal für Anfänger
 Alle Kommentare als Feed abonnieren

Ein Kommentar zu “Nextcloud warnt inzwischen auch bei zu alter PHP-Version”

  1. Jürgen Hoffmann sagt:

    Ja, NC warnt zwar, macht aber ungeachtet dessen ein Update der Mail-App auf V1.6, die zwingend PHP 7.3 braucht. Wird vorher nicht angekündigt (ich habe jedenfalls keinen Hinweis gefunden). Sonst läuft sie nicht mehr (bei mir der Fall). Hätte ich mal dein WE abgewartet 😉

Antworten

Air VPN - The air to breathe the real Internet