Dummy Output! Plötzlich kein Sound mehr unter Linux Mint 15? Hier ist die Lösung …

30 Juli 2013 12 Kommentare Autor: Jürgen (jdo)

Linux Mint Logo 150x150Gestern bin ich auf ein eigenartiges Problem gestoßen. Am Vortag hatte ich das Samsung Ultrabook noch ganz normal heruntergefahren und am nächsten Tag funktioniert die Soundkarte plötzlich nicht mehr. Ich hatte nur noch ein “Dummy Output” zur Auswahl.

Sehr eigenartig. Zunächst habe ich im eigenen Gehirn nachgesehen, ob ich etwas verstellt hatte – eigentlich nicht. Zumindest nicht zwischen dem letzten Herunterfahren und wieder Hochfahren.

Kamen komische Updates? Kernel-Updates? Eigentlich auch nicht. Also die Suchmaschine angeworfen. Dieser Bug-Report meint, dass es angeblich ein Problem bei Ubuntu 13.04 “Raring Ringtail” generell sei. Es hänge wohl mit Kernel 3.8 zusammen. Allerdings habe ich auch Foreneinträge gefunden, bei denen sich Anwender über ähnliches Verhalten bei früheren Mint-Versionen beklagten.

Zunächst sehen wir mal nach, ob die Soundkarte auch noch vorhanden ist. Nur vorsichtshalber, weil sie kann ja nicht wirklich abgehauen sein: lspci -v | grep -A7 -i "audio"

Sollte es hier eine Ausgabe geben, dann ist die Soundkarte noch da. Der Screenshot ist auf einem anderen Rechner gemacht und soll nur als Beispiel dienen. Hier läuft Kubuntu 13.04 und ich hatte das Problem noch nicht. Aber wie gesagt – andere Hardware. Der Befehl sagt mir, dass eine Soundkarte vorhanden ist – sehr schön, nur Lärm macht sie keinen mehr.

lspci-Ausgabe

lspci-Ausgabe

Der Befehl sudo aplay -l gab allerdings aus, dass keine Soundkarte verfügbar ist. Was bei mir funktioniert hat, war dem Kernel beim Start den Parameter pci=use_crs mit auf den Weg zu geben. Da kannst DU über die Datei /etc/default/grub realisieren. Die Datei hat bei mir unter Linux Mint 15 nicht existiert, deswegen musste ich sie zunächst anlegen. Dort kopierst Du dann folgende Zeile hinein: GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash pci=use_crs”

Danach speicherst Du die Datei, schließt sie und führst folgenden Befehl aus: sudo update-grub. Nun hat die Soundkarte nach einem Neustart wie gewohnt funktioniert.



Du kannst gerne Deinen Senf zu diesem Beitrag geben: Hier geht es zu den Kommentaren


Schreiben macht durstig! Eine kleine Erfrischung kann daher nie schaden. Wem dieser freie Artikel gefallen hat, der darf mir gerne einen frisch gezapften Hopfen-Tee ausgeben (Paypal - der Spenden-Knopf
oder bitcoin - Adresse: 1NacVNwcLLePUVv8uSafu5Ykdwh8QyDfgK). Ich freue mich über jede noch so kleine Spende. Vielen Dank und Prost!
 Alle Kommentare als Feed abonnieren

12 Kommentare zu “Dummy Output! Plötzlich kein Sound mehr unter Linux Mint 15? Hier ist die Lösung …”

  1. Erik sagt:

    Ich habe zwar das Problem nicht, aber ich würde gerne den Hintergrund zu "pci=use_crs" wissen, leider finde ich nix genaues, nur Menschen die es auch nicht wissen: "Finally got sound using pci=use_crs on the grub boot line. Don't know what the hell this does" Aber ich bin doch so neugierig ... ;-)

    Kann da draußen uns Unwissenden ein wenig Licht ins Dunkle bringen? Danke. :-)

    • jdo sagt:

      Bei Red Hat wird es so beschrieben: Symptom: Some PCI devices might appear to be missing from the system. Solution: The kernel boot parameter 'pci=use_crs' is required to access all PCI devices in the system. Without this boot parameter, devices behind PCI bridges will not be seen.

      Was nun aber nicht erklärt, warum es vorher ging. Hilft das?

  2. postlet sagt:

    Diese Kernel-Angelegenheiten, die ja an der absoluten Basis des Betriebssystems stattfinden, werden mir trotz aller fortgeschrittenen Kenntnisse wohl ein Rätsel bleiben. CRS = Current Resource Settings und das ist ein Kernel Parameter, der irgendwas tut, das man mit dem Verständnis von tiefgründigen Grundlagen unter Suchbegriffen wie bspw. " kernel crs" nachlesen kann.

    Mitunter: https://wiki.ubuntu.com/Kernel/Reference/fwts/crs

    Gibt bestimmt jemandem, dem das was sagt. Irgendwas mit BIOS, Kernel und Aktualität …

    Unabhängig davon, möchte ich mich Erik anschließen, dass gerade solche Dinge auch meiner Meinung nach einer sorgfältigeren Erklärung bedürfen, denn lediglich "Dem tut!". Und sei es nur der eindeutige Hinweis, dass man als Autor sehr froh ist, dass dem tut, man aber NULL Plan hat "warum!?"

    • jdo sagt:

      Ich weiß nicht, was an dem Link zu Red Hat missverständlich ist. Der Kernel kann plötzlich aus irgendeinem Grund nicht mehr hinter die eine PCI Host Bridge sehen und initialisiert die Soundkarte nicht.

      Wenn ich das nächste Mal auf ein Problem stoße und eine Lösung finde, erwäge ich diese für mich selbst zu behalten. Dann muss man sich wenigstens nicht dumm anreden lassen, wenn man anderen mit dem selben Problem helfen möchte.

      Wenn mein Auto nicht mehr anspringt und das Problem liegt an der Batterie, erklärt mir der Mechaniker auch nicht die chemischen Prozesse, die zu einem Ausfall geführt haben und keiner fragt nach, warum. In diesem Beitrag ging es primär darum , die Soundkarte wieder flott zu machen und nicht um einen Crashkurs im Kernel-Hacking.

      • postlet sagt:

        Was wäre denn jetzt so schwer daran gewesen, bereits im eigentlichen Artikel darauf hinzuweisen?

        Der Zusammenhang wäre einfach interessant gewesen, weil dieser Kernel-Parameter ja nicht nur die Soundkarte wieder flott macht, sondern generell hilft, wenn PCI-Gräte hinter einer solchen PCI Bridge nicht erkannt werden.

        Tut mir leid, wenn du dich von mir auf die Füße getreten fühlst, aber deine Antowrt auf den ersten Kommentar hätte ich eben schon im Artikel selber erwartet.

      • Haggle sagt:

        Es mag nicht ausführlich erklärt worden sein, aber hey es ist ein Hinweis und man kann ja selber nach tiefgründigeren Erklärungen suchen, wenn man mehr wissen will.
        Mir hat es sofort geholfen, also danke!

  3. Michael sagt:

    Danke für die Lösung.
    Bei mir auf meinem Asus 1215b passiert dieser Dummy-Output Fehler alle paar Tage mal und da half bisher immer nur stupides Neustarten des Rechners. Nun hoffe ich das es eine dauerhaftere Behebung des Fehlers ist :)

  4. werner sagt:

    Hallo JÜRGEN (JDO),

    eine kurze und vor allem sehr präzise Anleitung
    für alle LMint und höffentlich auch Ubuntu Fans.

    Ich bedanke mich sehr.

    Diese Homepage habe ich mir auf längere Zeit festgehalten.

  5. Wolfgang sagt:

    Hallo Jürgen,
    bin regelmäßiger Leser Deines Blogs und habe schon sehr viele gute Tips von hier erhalten und umsetzten können.Dafür möchte ich mich an dieser Stelle und aus "gegebenen Anlass" recht herzlich bedanken.
    Mach weiter so!!!

  6. F-Esch sagt:

    Mit hat der Kernel Parameter nicht weitergeholfen.

    Nach einem Neustart mit dem Parameter findet "sudo aplay -l" keine Soundkarte!

    Ich suche weiter nach einer Lösung

  7. El Joe sagt:

    Hallo zusammen,
    hatte im mint16 das gleiche Problem.
    Nach dem ersten Reboot alles wieder ok. Werde das natürlich noch verfolgen müssen.
    Danke & Gruß

Antworten